Back to overview
Degraded
Banking services are unavailable
Aug 09 at 05:41pm EDT
Affected services
app.retirable.com
Resolved
Aug 09 at 06:31pm EDT
The issue has been resolved. All services are back online
Affected services
Created
Aug 09 at 05:41pm EDT
Our banking technology provider, Unit, is currently experiencing an outage. This will cause degraded service for the banking features in the Web/Mobile Dashboard.
Unit incident status here: https://status.unit.co/incidents/tz7l0vh0y570
Affected services